Rev 497 Linux & Windows Test

Post any feedback, problems and bugs from the Pre-Alpha releases here.

Moderator: Spudsdude

Rev 497 Linux & Windows Test

Postby jason34787 » Thu Jan 07, 2010 6:46 pm

First off, WOW! Great work guys I am really impressed by this application. It is already my favorite media manager!

Now, here is what I am doing and some results..

I've installed Umm on my headless Ubuntu 9.10 HTPC. I'm running Mono 2.4.2.3. I also installed it on my Windows Vista machine.

I fired up the ummServer.exe on the HTPC and ummClient.exe on the windows machine and it works great. I wasn't able to make it crash, it scraped my test movies, I was able to pick from a BUNCH of new movie posters, XBMC picked them right up after a library refresh. Sweet!

The one issue I'm facing is on the Ubuntu box I can connect to the server with the Client, I can scan the movie DB, but as soon as I select a movie it crashes out. I guess it is a mono issue, since the client is working on Windows.

Here is error I get in terminal.

=================================================================
Got a SIGABRT while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.
=================================================================

I'll report back more later. Keep up the great work! Let me know if I can help testing something specific.


****UPDATE****

I installed Umm on my laptop, running Ubuntu Karmic, with Mono-complete, Mediainfo 0.7.25.. Running the Client, I am getting the same behaviour, it will open up and scan movies. As soon as I try to click on a movie it crashes. Not sure what to try here. I can keep testing on Windows.
jason34787
Official Tester
Official Tester
 
Posts: 4
Joined: Tue Jan 05, 2010 6:16 pm

Re: Rev 497 Linux & Windows Test

Postby Spudsdude » Fri Jan 08, 2010 2:06 am

try running the client with
mono --debug ummClient.exe > log.txt
and pastebin the log it generates after a crash
User avatar
Spudsdude
Team umX Developer
Team umX Developer
 
Posts: 440
Joined: Fri Sep 04, 2009 9:06 pm

Re: Rev 497 Linux & Windows Test

Postby jason34787 » Fri Jan 08, 2010 5:01 pm

Hi Spuds,

The log had only one line: Initializing Component Complete.

When I used a -v I got a lot of stuff that means nothing to me, hopefully it will to you guys.

http://pastebin.com/m77525124
jason34787
Official Tester
Official Tester
 
Posts: 4
Joined: Tue Jan 05, 2010 6:16 pm

Re: Rev 497 Linux & Windows Test

Postby Spudsdude » Fri Jan 08, 2010 6:22 pm

think i found the issue,

give 514 a try
viewtopic.php?f=70&t=277

you can just extract to a different folder, if extracting to the same folder as your previous install, remove the config.xml and the databases as the schema/config options might (prob) changed.
User avatar
Spudsdude
Team umX Developer
Team umX Developer
 
Posts: 440
Joined: Fri Sep 04, 2009 9:06 pm

Re: Rev 497 Linux & Windows Test

Postby jason34787 » Fri Jan 08, 2010 7:28 pm

Yes! The Client is now working with Server on Ubuntu 9.10 locally. I will try it on my Laptop across the network when I get home.

I have scraped Movies and TV with much success. Umm in Pre-Alpha is already kick ass..

I'm interested in how I can be the most help. I've noticed features that seem to be missing, but I'm not sure if they are planned or not. For instance, I can't seem to have images automatically added for TV Shows or Movies, I have to go in an manually add them.
jason34787
Official Tester
Official Tester
 
Posts: 4
Joined: Tue Jan 05, 2010 6:16 pm

Re: Rev 497 Linux & Windows Test

Postby Montellese » Fri Jan 08, 2010 7:35 pm

jason34787 wrote:I'm interested in how I can be the most help. I've noticed features that seem to be missing, but I'm not sure if they are planned or not. For instance, I can't seem to have images automatically added for TV Shows or Movies, I have to go in an manually add them.


You are already helping us by your feedback and your testing. We can really need people who are willing to thoroughly test our releases and give us feedback (whether it is good or bad).
If you want to help even more write everything down you are missing. Post them here in the Feature Request board with a short description of what you have in mind. Remember to check the already existing Feature Requests in our Trac. You can also create new feature requests there but please also create a thread in the forum so we can discuss it.

If you have experience with software development you can also join our team and work on UMM directly. We are always looking for people to support us.

Thanks for your help. It's very much appreciated :D
User avatar
Montellese
Team umX Developer
Team umX Developer
 
Posts: 288
Joined: Sat Sep 05, 2009 6:15 am
Location: Oberuzwil (CH)


Return to Pre-Alpha

Who is online

Users browsing this forum: No registered users and 1 guest

cron