Images from themoviedb.org cannot be downloaded (HTTP 404)

Post any feedback, problems and bugs from the Pre-Alpha releases here.

Moderator: Spudsdude

Images from themoviedb.org cannot be downloaded (HTTP 404)

Postby Montellese » Thu Oct 29, 2009 3:02 pm

Ok I already raised a bug ticket for it: https://sourceforge.net/apps/trac/universalmc/ticket/20
Description is there and I also located the real problem but couldn't find the code messing it up yet (but I'll keep looking).
User avatar
Montellese
Team umX Developer
Team umX Developer
 
Posts: 288
Joined: Sat Sep 05, 2009 6:15 am
Location: Oberuzwil (CH)

Re: Images from themoviedb.org cannot be downloaded (HTTP 404)

Postby Spudsdude » Thu Oct 29, 2009 4:04 pm

fixed in svn rev 269
was an extra . in the output expression for the scraper
\1.\2 when it should have been \1\2

fixed area is bolded
<GetTMDBThumbs dest="5">
<RegExp input="$$4" output="&lt;details&gt;\1&lt;/details&gt;" dest="5">
<RegExp input="$$1" output="&lt;thumb preview=&quot;\1_mid\2&quot;&gt;\1\2&lt;/thumb&gt;" dest="4">
<expression repeat="yes">&lt;poster size=&quot;original&quot;&gt;([^&lt;].*?)(\.jpg|\.png|\.gif).*?&lt;/poster&gt;</expression>
</RegExp>
<expression noclean="1"/>
</RegExp>
</GetTMDBThumbs>
User avatar
Spudsdude
Team umX Developer
Team umX Developer
 
Posts: 440
Joined: Fri Sep 04, 2009 9:06 pm

Re: Images from themoviedb.org cannot be downloaded (HTTP 404)

Postby Montellese » Thu Oct 29, 2009 4:33 pm

Thanks :-) At least I could also test the new downloader I'm working on with invalid URLs ;-)
User avatar
Montellese
Team umX Developer
Team umX Developer
 
Posts: 288
Joined: Sat Sep 05, 2009 6:15 am
Location: Oberuzwil (CH)


Return to Pre-Alpha

Who is online

Users browsing this forum: No registered users and 1 guest

cron